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AIRPORT’S CHART VIEWER V3.0

USER’S MANUAL

DESCRIPTION

Airport’s Chart Viewer v3.0 is a program that will generate and display a map of all the taxiways (with their ids), gates, parkings, ILS, and runways of any airport of the FS2002 world. View two airports charts almost at same time. Now, you can save any airport’s chart in an image file. Loads all the FS2002 airports more faster than the earlier versions. A new hot key for show/hide the chart’s window without pausing your FS2002. Requires that you had installed any earlier version of Airport’s Chart Viewer. Created by Manuel Ambulo

INSTALLING THE AIRPORT’S CHART VIEWER PROGRAM

Requires you have installed in your computer, any earlier version of Airport’s Chart Viewer. Unzip all the files contained in the ZIP file, in the directory where you installed the earlier version of Airport’s Chart Viewer. If  when you are unzipping the files from the ZIP file, it asks you, if you want to replace some existing files, then press the “OK” button, that means, that you must replace those existing files with the new files that are inside the ZIP file. After, this run Airport’s Chart Viewer v3.0, it needs to create again the database files, because the new database files has a different format.

HOW IT WORKS?

You run the “Airport’s Chart Viewer” program. Then you select the two airports (departure and destination airports), and this program will generate and display a map or graphic of all the taxiways, gates, parkings, ILS, airspaces and runways of the current selected airport, that you selected. This map will allow the pilots to know where is each taxiway, in the current selected airport, so they don’t need to request a progressive taxi to the ground controller. It also displays the current altimeter setting, that you must set in your “kollsman window” of your altimeter, this feature is very useful when you download Real Weather. The window of this program is so little, that you can be flying or taxiing or looking at the control panel’s instrument, while you are looking at the map or graphic that this program had generated and displayed, without pausing the FS2002’s simulation. (Also, you can use Airport’s Chart Viewer when your FS2002 is in full screen mode).

RUNNING THE AIRPORT’S CHART VIEWER PROGRAM
1- Run “Airport Chart Viewer v30.exe”.

2- Wait until it loads.
3- If this is the first time that you are running the “Airport Chart Viewer” program, then it will appear the “Settings” window.
4- In the “Settings” window, you must select your Flight Simulator’s version, that must be the FS2002. And also you must choose or select your Microsoft Flight Simulator's main folder, from the browser. After that, you must click the “NEXT STEP (” button, in order, to create the settings file for this program.
5- Then it will appear, the “Choosing an airport” window, if this is the first time that you are running the “Airport Chart Viewer” program, then it will read all the AFD scenery files containing the information about all the airports of the FS2002 world, and then it will create the database file with that information. (This process can take a few minutes, so please wait).

6- After that process, this program will notify you, that the creation of the database file was completed. Then it will create one list with the all the airports ICAO_IDs and names of the FS2002 world.

7- After this, you must type or write the ICAO_ID of your departure airport, in the “FS2002 World Airports” list.

[image: image2.png]FS2002 World Aipots

freto

Set as Departure Aipart || St as Destination Afpart
~Main Aiports

Depattwefipot [
Destiationipatt [

Seanring: Dore.

T
GET AIRPORT CLOSE_PROGRAM





8- Then “drop-down” this list and select the ICAO_ID with the name of your departure airport.
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9- And click the “Set as Departure Airport” button, for set the current selected airport as your “Departure Airport”.

NOTE: If you want to replace the current airport that you had set as your departure airport, by another airport, then repeat the steps 7, 8, and 9.
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10- Now, you must type or write the ICAO_ID of your destination airport, in the “FS2002 World Airports” list.
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11- Then “drop-down” this list and select the ICAO_ID with the name of your destination airport.
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12- And click the “Set as Destination Airport” button, for set the current selected airport as your “Destination Airport”.

NOTE: If you just want, to fly around one airport, then you must select the same airport as your departure and destination airport. If you want to replace the current airport that you had set as your destination airport, by another airport, then repeat the steps 10, 11, and 12.
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13- If you have installed the FSUIPC module, then you must run your FS2002. And load the simulation at the departure airport that you had selected from the list (From the departure airports list of this program). If you have your FS2002 set to full screen mode, then turn it to the window mode. After that, you must minimize it. (If you don’t have installed the FSUIPC module and you want to install it, you can download it at the FSUIPC’s official web site: http://www.schiratti.com/dowson.html).

IMPORTANT NOTE: This program doesn’t need the FSUIPC module, in order, to run. But i recommend you to download and install it. 

14- Then you must click the “GET AIRPORT” button.

15- Wait until, this program had gathered all the information of boths airports (departure and destination airports).

16- If you don’t installed the FSUIPC module, then it will appears a message box telling you that this program couldn’t connect to the FS2002. 

17- Then it will appear the main window, that will show the map or chart of the departure airport that you selected. Then you MUST zoom in (By clicking in the “+” button), in this program’s window, until you can see the airport (The airport will appear about in a zoom rate of 38x). After that, you can maximize the FS2002, and place this program’s window, in a place, so you can see part of the control panel. If you want to resize this program’s window, just click and drag the lower-right corner of this window.




IMPORTANT NOTE: If you don’t have installed the FSUIPC module, this program will display the map or chart of the current airport that you selected, but it will not display your plane’s position, and will not display the altimeter setting number. (For more information about the “Altimeter Setting”, see the FS2002 “ATC HandBook” document).

DISPLAY THE DEPARTURE AIRPORT’S CHART

If you want to display the departure airport’s chart, that you had selected, then you must press the key “1”, from your keyboard, without pausing the FS2002. Another way, for display the departure airport’s chart, is by pausing the FS2002, and clicking the “View” menu from this program’s window, and selecting the “Departure Airport’s Chart”.

IMPORTANT NOTE: Remmember, that the FS2002’s keyboard configuration, could has another event assigned for the key “1”. Each time you change the between the departure and destination airports charts, the “Follow Aircraft” option, will going to be disabled. This occurs because this program needs to center the screen in the departure airport’s location.

DISPLAY THE DESTINATION AIRPORT’S CHART

If you want to display the destination airport’s chart, that you had selected, then you must press the key “2”, from your keyboard, without pausing the FS2002. Another way, for display the destination airport’s chart, is by pausing the FS2002, and clicking the “View” menu from this program’s window, and selecting the “Destination Airport’s Chart”.

IMPORTANT NOTE: Remmember, that the FS2002’s keyboard configuration, could has another event assigned for the key “2”. Each time you change the between the departure and destination airports charts, the “Follow Aircraft” option, will going to be disabled. This occurs because this program needs to center the screen in the destination airport’s location.

ZOOM IN THE CURRENT DISPLAYED AIRPORT’S CHART

If you want to zoom in the current displayed airport’s chart, then you must press the key “+” from your keyboard’s numpad keys, without pausing the FS2002. Another way, for zoom in the current displayed airport’s chart, is by pausing the FS2002, and clicking the “+” button in this program’s window.

IMPORTANT NOTE: Remmember, that the FS2002’s keyboard configuration, could has another event assigned for the key “+”.

ZOOM OUT THE CURRENT DISPLAYED AIRPORT’S CHART

If you want to zoom out the current displayed airport’s chart, then you must press the key “-” from your keyboard’s numpad keys, without pausing the FS2002. Another way, for zoom out the current displayed airport’s chart, is by pausing the FS2002, and clicking the “-” button in this program’s window.

IMPORTANT NOTE: Remmember, that the FS2002’s keyboard configuration, could has another event assigned for the key “-”.

CENTERING THE CURRENT DISPLAYED AIRPORT’S CHART

You can center the current displayed airport’s chart image by clicking the “C” button, in this program’s window. Each time you center the current displayed airport’s chart, the “Follow Aircraft” option, will going to be disabled. This occurs because this program needs to center the screen in the location that you selected.

PAUSING/RESUMING THE REFRESHING OF THE CURRENT DISPLAYED AIRPORT’S CHART

If you want to pause the refreshing of the current displayed airport’s chart, you must press the key “A” of your keyboard, without pausing the FS2002. Another way, for pause the current displayed airport’s chart, is by pausing the FS2002, and then clicking the “Options” menu, in this program’s window, then selecting the “Pause/Resume Current Chart’s Refreshing”. If you want to resume the refreshing of the current displayed airport’s chart, then you must press again the key “A” of your keyboard, without pausing the FS2002. Or, you can choose the other way, that is, pausing the FS2002, and then clicking the “Options” menu, then the “Pause/Resume Current Chart’s Refreshing”.

IMPORTANT NOTE: If you pause the refreshing of the current displayed airport’s chart, then you will not be able to zoom in, zoom out, center the chart, and change between the departure and destination airports charts. For enable these functions, you must resume the refreshing of the current displayed airport’s chart. (This program refreshes the current displayed airport’s chart each 2 seconds.). Remmember, that the FS2002’s keyboard configuration, could has another event assigned for the key “A”.

SHOWING/HIDING THE CHART’S WINDOW WITHOUT PAUSING YOUR FS2002

If you want to hide the chart’s window without pausing your FS2002, you must press the key “H” of your keyboard. Another way, for hide the chart’s window, is by pausing the FS2002, and then clicking the “View” menu, in this program’s window (Chart window), then selecting the “Show/Hide Chart Window”. If you want to show the chart’s window without pausing your FS2002, you must press, again, the key “H” of your keyboard. Or, you can choose the other way, that is, pausing the FS2002, and then clicking the “View” menu, then the “Show/Hide Chart Window”.

IMPORTANT NOTE: Remmember, that the FS2002’s keyboard configuration, could has another event assigned for the key “H”.
ENABLE/DISABLE THE “FOLLOW AIRCRAFT” OPTION

If you want to enable the “Follow_Aircraft” option, without pausing your FS2002, you must press the key “F” of your keyboard. Another way, for enable the “Follow_Aircraft” option, is by pausing the FS2002, and then clicking the “Options” menu, in this program’s window (Chart window), then selecting the “Preferences”. It will appear the “Options” window, then check the “Follow Aircraft” option and press the “Ok” button. If you want to disable the “Follow_Aircraft” option, without pausing your FS2002, you must press, again, the key “F” of your keyboard. Or, you can choose the other way, that is, pausing the FS2002, and then clicking the “Options” menu, then the “Preferences”. It will appear the “Options” window, then uncheck the “Follow Aircraft” option and press the “Ok” button.

IMPORTANT NOTE: Remmember, that the FS2002’s keyboard configuration, could has another event assigned for the key “F”.

CHANGING THE ASSIGMENTS OF YOUR KEYBOARD’S KEYS

If you want to change the current default assigments for the events:

1- Zoom in, default assigned key: [+] key (numpad’s key)

2- Zoom out, default assigned key: [-] key (numpad’s key)

3- Display departure airport’s chart, default assigned key: [1]

4- Display destination airport’s chart, default assigned key: [2]

5- Pause/Resume the current chart’s refreshing, default assigned key: [A]

6- Show/Hide Chart Window, default assigned key: [H]

7- Enable/Disable Follow Aircraft Option, default assigned key: [F]

For change the current assigments, you must follow these steps:

1- Go to the “Options” menu, of this program’s window. Then select “Keyboard Assigments”.

2- It will appear the “Keyboard Assigments” window. In this window, is listed all the currently avaible events with theirs assigned keys.

3- Select and double click the event, that you want change the current key assigned.

4- It will appear the “Change key assigment” window. Here you must press the key, in your keyboard, that you want to assign to the current selected event. Then after you had pressed the key, it will appear in the “New Key” field, if you had pressed the wrong key, then you must press the “Try Again” button, and try it again. And, when you had finished, just click the “Ok” button.

5- The “Change key assigment” window will disappear and it will appear the “Keyboard Assigments” window. If you want to make more changes, you can do it, by repeating the process from the step 3 to the step 4.

6- Press “Ok” in the “Keyboard Assigments” window, when you had finished.

NOTE: I recommend you to use keys that are not currently in use in the FS2002, i mean, try to use keys that are not currently assigned to any event in the FS2002 keyboard’s assigments configuration.

DISPLAYING THE CURRENT DISPLAYED AIRPORT’S FREQUENCIES

If you want to display the frequencies that has the currently displayed airport, then you must go to the “View” menu, in this program’s window, and select the “Show Current Airport’s Frequencies”.

PRINTING CURRENT DISPLAYED AIRPORT’S CHART

If you  want to print the current displayed airport’s chart, then you must go to the “File” menu, in this program’s window, and select “Print Current Chart”. (It will use your default printer).

SAVING IN A PICTURE FILE THE CURRENT DISPLAYED AIRPORT’S CHART

Go to the menu "File", then select and click "Save to an Image File", then it will save the current displayed airport’s chart in a picture file (in *.JPG format), then go to the directory, where you installed you installed Airport’s Chart Viewer v3.0, and then you will see the picture file with the name of the airport, doble click it, and then it will be displayed.

NOTE: If you have problems with the “Print Current Chart” option, of Airport’s Chart Viewer, then you can use this option ("Save to an Image File"), for save the current displayed airport’s chart, in a picture file, for then open it and print it, with any drawing or painting program. 

CHANGING THE DEPARTURE AND DESTINATION AIRPORTS

If you want to change the currently departure and destination airports, then you must go to the “File” menu, in this program’s window, and select “Load Airports List”. Then it will appear the “Choosing an airport” window, wait until it loads, and select the departure and destination airports, then click the “GET AIRPORT” button.

CONTROLLING THE DISPLAY OF THE OBJECTS IN THE CHART

You can control the display of the objects that you want in the chart. To do this, you must go to the “Options” menu, in this program’s window, then select “Preferences”. It will appear the “Options” window. Here, you must check or uncheck the objects, that you want to display in the chart. Also you can set the units of measurement of the displayed altimeter settin. When you had finished press the “Ok” button.

***DISPLAY OF AIRSPACES DISABLED IN THIS VERSION 3.0***

I disabled the load and display of the default airspaces of the FS2002’s world, because, i think that you don’t need to see the airspaces outlines or boundaries, because the default FS2002’s ATC window will tell or notify you automatly, when you enter or leave an airspace. Now, that i disabled this, your PC perfomace will increase, and Airport’s Chart Viewer will use less memory than the version 2.5. And that’s why, you can see, that Airport’s Chart Viewer loads all the FS2002’s world airports more faster, than any earlier version.

CLOSING AIRPORT’S CHART VIEWER PROGRAM

If you just want to close this program, then you must click the “X” button of the window that shows the map or chart. Or if you have displayed the “Choosing an airport” window, then you must click the “CLOSE_PROGRAM” button.

KNOWN BUGS

There is currently no bugs. If you had found a bug, then e-mail me.

NOTES BY THE AUTHOR

The reason, that explains why i designed this program, is because it is difficult to get the original chart of an specific airport, in the moment when you need it, specialy when you are playing in a FS2002 multiplayer session, and you need to know where are located the airspaces, taxiways, gates or parkings of an specific airport. I hope that this program could help you. And have fun!. For any comments, suggestions or report of bugs, please e-mail me at: netghost82@hotmail.com 

MY NEW WEB SITE

**Now you can visit my new web site, with the lastest versions

of my programs: http://www.joachimheimfeld.de/manuel/
SPECIAL THANKS TO

· Microsoft Flight Simulator’s Team, by the SDKs.
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· Manfred Moldenhauer (SCASM documentation).
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· Alessandro Antonini (Who wrote BGLASM).
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***THIS IS A FREEWARE PROGRAM SO, PLEASE DON’T DISTRIBUTE THIS PROGRAM OR THIS DOCUMENT FOR COMMERCIAL PURPOSES WITHOUT THE AUTHOR’S PERMISSION***

THE END, HAVE FUN!!!
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